University of Missouri
IT System Status
Zoom Outage
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Jun 24, 2019 - 13:37 CDT
Investigating
Zoom is currently experiencing an outage. No ETA on a fix but Zoom is aware.

https://status.zoom.us/
Posted Jun 24, 2019 - 13:37 CDT
This incident affected: Other UM IT Services.