University of Missouri
IT System Status
O365 Updates
Incident Report for UM IT Systems
Resolved
This was completed without issue.
Posted Oct 17, 2019 - 14:24 CDT
Monitoring
The afternoon of 10/16 the Exchange team will be removing the contacts in O365 for ineligible employees. Please contact Tech Support if you believe this has affected your ability to send mail to an employee of the University.
Posted Oct 16, 2019 - 10:08 CDT
This incident affected: Faculty/Staff Email.