University of Missouri
IT System Status
IT Campus Help Desk phone
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact the Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Oct 22, 2021 - 11:22 CDT
Identified
Due to the network outage, the IT Help Desk phones are not working. Technicians are working to resolve it. Please visit help.missouri.edu to log an incident ticket.
The estimated time to resolution is unknown.
Posted Oct 22, 2021 - 10:32 CDT
This incident affected: Phone Services, Other MU IT Services, and Other UM IT Services.