University of Missouri
IT System Status
myHR
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Apr 17, 2017 - 13:15 CDT
Monitoring
Technicians have taken corrective action. They will continue to monitor the service performance and ask that any customer issues be reported to Tech Support at 573. 882-5000 or by clicking the chat button at doit.missouri.edu during business hours.
Posted Apr 17, 2017 - 10:24 CDT
Investigating
Customers are reporting issues with this service when logging in from off-campus. Technicians are looking into the issue to determine if there is a problem.
Posted Apr 17, 2017 - 09:37 CDT
This incident affected: PeopleSoft HR.