University of Missouri
IT System Status
Turnitin
Incident Report for UM IT Systems
Resolved
Turnitin has issued an all clear. Service was fully restored by 12:41 p.m. CST.
Posted Nov 13, 2019 - 13:18 CST
Investigating
Turnitin reported experiencing an ongoing service disruption about 10:30 a.m. CST, November 13. During this time, you may find that you are unable to make a submission or that uploading submissions takes longer than expected.
Posted Nov 13, 2019 - 11:14 CST
This incident affected: Other MU IT Services.