University of Missouri
IT System Status
Microsoft Teams
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Jul 08, 2020 - 11:02 CDT
Investigating
User Impact: Some users may be unable to access the Teams service or some of its features.

More info: Users may also experience issues joining Teams meetings.
Posted Jun 11, 2020 - 10:04 CDT
This incident affected: Other MU IT Services and Other UM IT Services.