University of Missouri
IT System Status
File Services
Incident Report for UM IT Systems
Resolved
This status can now be lifted and marked resolved. Thank you.
Posted Dec 13, 2018 - 12:49 CST
Investigating
UMSL users are reporting connectivity issues to Enterprise and Economy file services. Technicians are investigating the issue.
Posted Dec 11, 2018 - 11:20 CST
This incident affected: Other UM IT Services.