University of Missouri
IT System Status
UM Web Apps - Security Certificate Has Expired
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Sep 24, 2018 - 09:28 CDT
Investigating
We are receiving reports that the security certificate for UM Web Applications (https://webapps.umsystem.edu) has expired. Technicians have been notified of the issue.
Posted Sep 24, 2018 - 07:51 CDT
This incident affected: UM Web Applications.