University of Missouri
IT System Status
DoIT website
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Dec 03, 2019 - 11:54 CST
Investigating
The Division of IT (DoIT) website at https://doit.missouri.edu is down and technicians are working on the problem.
Posted Dec 03, 2019 - 11:23 CST
This incident affected: Other MU IT Services.