University of Missouri
IT System Status
Cherwell
Incident Report for UM IT Systems
Resolved
Vendor is confident after some changes this service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Dec 04, 2019 - 19:15 CST
Investigating
Cherwell is experiencing slow performance. The issue is being investigated.
Posted Dec 04, 2019 - 14:54 CST
This incident affected: Other UM IT Services.