University of Missouri
IT System Status
VitalSource eBooks
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Jul 02, 2020 - 13:26 CDT
Monitoring
VitalSource has implemented a fix that has restored service to users. They continue to monitor for further issues.
Posted Jun 29, 2020 - 12:09 CDT
Identified
VitalSource eBooks are not available. Any user trying to access an eBook using VitalSource directly or through Canvas will receive an error message. The vendor has identified the issue and is working on a resolution.

https://status.vitalsource.com/incidents/y933j8lfb9
Posted Jun 29, 2020 - 11:14 CDT
This incident affected: Canvas LMS.