University of Missouri
IT System Status
Adobe for UMsystem.edu
Incident Report for UM IT Systems
Resolved
Adobe login is functional again for umsystem.edu users.
Posted Jul 27, 2020 - 14:47 CDT
Investigating
Sign in to Adobe creative cloud for UMsystem.edu users is currently experiencing problems. Technicians are investigating the issue.
Posted Jul 27, 2020 - 13:11 CDT
This incident affected: Other MU IT Services and Other UM IT Services.