University of Missouri
IT System Status
Phone service
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Dec 03, 2019 - 16:59 CST
Update
We are continuing to investigate this issue.
Posted Dec 03, 2019 - 16:04 CST
Update
We are continuing to investigate this issue.
Posted Dec 03, 2019 - 16:00 CST
Investigating
CenturyLink is currently experiencing issues dialing toll free numbers, as well as intermittent issues with long distance as well as AT&T connectivity. This outage will also affect credit card machines. This issue is affecting Centurylink customers throughout Columbia.
Posted Dec 03, 2019 - 14:54 CST
This incident affected: Phone Services.