University of Missouri
IT System Status
Exchange Mail Routing Issues with Live.edu
Incident Report for UM IT Systems
Resolved
Microsoft has removed the IP blocks that caused this outage. This service is now fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Jul 27, 2018 - 10:36 CDT
Identified
The Exchange Messaging team is investigating mail delivery issues to Live, MSN, Outlook.com, and Hotmail email addresses. We believe this is due to compromised accounts sending mail that resulted in the blacklist of a few of our outbound IronPort appliances. The Messaging team has implemented a temporary workaround as these blacklists are corrected. If you continue to see mail delivery issues to these domains, please contact Tech Support at 573-882-5000.
Posted Jul 09, 2018 - 17:00 CDT
This incident affected: Faculty/Staff Email, Student Email, Other MU IT Services, and Other UM IT Services.