University of Missouri
IT System Status
Box
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Aug 13, 2019 - 14:57 CDT
Investigating
Customers are reporting Box logins are failing. Technicians are looking into the issue.
Posted Aug 13, 2019 - 14:12 CDT
This incident affected: Other UM IT Services.