University of Missouri
IT System Status
VPN
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted May 29, 2020 - 09:51 CDT
Investigating
Reports of reported vpn issues. Technicans are looking into it.
Posted May 29, 2020 - 08:44 CDT
This incident affected: Other MU IT Services and Other UM IT Services.