University of Missouri
IT System Status
Outlook Web Acess (OWA) issues for Exchange Online Mailboxes
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact your campus Help Desk.
Posted Jun 05, 2020 - 13:24 CDT
Identified
The Division of IT has received notification from Microsoft that some Exchange Online users may experience Outlook on the Web (OWA) page loading issues. Users may see black bars or incorrect URLs within the header of OWA. Microsoft has identified that a service call associated with generating the header within OWA is behaving erratically, and getting throttled. They are investigating and will let us know once it is resolved
Posted Jun 02, 2020 - 12:54 CDT
This incident affected: Faculty/Staff Email and Student Email.