University of Missouri
IT System Status
Cherwell
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Aug 14, 2019 - 15:27 CDT
Identified
Cherwell Service is experiencing degraded service due to vendor connectivity issues. They have identified the issue and continue to actively apply a resolution.
Posted Aug 14, 2019 - 10:16 CDT
This incident affected: Other UM IT Services.