University of Missouri
IT System Status
Missouri.edu
Incident Report for UM IT Systems
Resolved
The website is fully functional again.
Posted Aug 20, 2019 - 11:12 CDT
Identified
Missouri.edu website is experience degraded service. Technicians are working to resolve the issue.
Posted Aug 20, 2019 - 08:38 CDT
This incident affected: Other MU IT Services.