University of Missouri
IT System Status
Cherwell Degradation Service Dallas Data Center performance issues
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Oct 21, 2019 - 10:57 CDT
Investigating
The Cherwell data center is experiencing performance issues and causing slowness in our Production Cherwell environment. Technicians are looking into the issue and we will send updates as we receive them.
Posted Oct 21, 2019 - 08:36 CDT
This incident affected: Other UM IT Services.