University of Missouri
IT System Status
PeopleSoft HR and Finance WebApps
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact the Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Oct 18, 2021 - 09:36 CDT
Identified
PeopleSoft HR and Finance WebApps is currently inaccessible. Technicians are actively working to restore services. Expected time to resolution is not known at this time.
Posted Oct 18, 2021 - 08:24 CDT
This incident affected: PeopleSoft Finance, UM Web Applications, and PeopleSoft HR.