University of Missouri
IT System Status
MU Connect
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Dec 20, 2018 - 09:40 CST
Update
MU Connect (Starfish) technical support has identified the root cause of the issue and is currently deploying a fix.
Posted Nov 27, 2018 - 14:31 CST
Identified
MU Connect (Starfish) is experiencing a partial outage. Appointments are not displaying on user’s calendars and students cannot schedule appointments with advisers. Starfish technical support is aware of the issue and is working to identify the cause.
Posted Nov 27, 2018 - 12:39 CST
This incident affected: Other MU IT Services.