University of Missouri
IT System Status
Web Apps - Financial Reporting
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Aug 15, 2017 - 11:07 CDT
Investigating
Customers are reporting issues with this service. When attempting to access Financials Reporting users are receiving an error page. Technicians are looking into the issue to determine if there is a problem.
Posted Aug 15, 2017 - 10:36 CDT
This incident affected: PeopleSoft Finance.