University of Missouri
IT System Status
Building a Foundation: Discrimination Prevention & Title IX - Mandatory Training
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Jul 19, 2017 - 12:08 CDT
Identified
The Division of IT has identified a problem with this service. Currently users are not able to complete the training due to an issue with one of the quizzes. Technicians are working to resolve the issue.
Posted Jul 13, 2017 - 09:51 CDT
This incident affected: Other UM IT Services.