University of Missouri
IT System Status
myVITA - Login Issues
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted May 23, 2018 - 16:30 CDT
Identified
It has been brought to our attention that a number of users are experiencing issues logging in to myVITA. The vendor is aware of the issue and has technicians working on a solution. An estimated time for resolution is currently unavailable. We will post updates here as we receive them.
Posted May 23, 2018 - 12:42 CDT
This incident affected: Other MU IT Services and Other UM IT Services.