University of Missouri
IT System Status
Phones - International Dialing
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Aug 13, 2019 - 08:46 CDT
Monitoring
International has been restored. Technicians will continue to monitor the situation.
Posted Aug 01, 2019 - 15:01 CDT
Investigating
Currently international dialing is unavailable. CenturyLink has been engaged and is investigating the issue.
Posted Jul 26, 2019 - 14:59 CDT
This incident affected: Phone Services.