University of Missouri
IT System Status
Exchange Mail Delivery Issues - From Microsoft Hosted Mail Providers
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Jul 31, 2020 - 09:44 CDT
Investigating
The Exchange team has been working multiple cases today regarding Microsoft hosted cloud services that have impacted the Outlook Mobile App and Federated Calendar sharing. We are also getting reports that some mail is not being delivered from Outlook.com, Hotmail.com or any other external customers that are hosted on Microsoft’s cloud mail service that is external to our domains. Mail is being delivered from our M365 hosted mailboxes between students and Faculty\Staff without issue due to our Hybrid Exchange setup. Technicians are still working with Microsoft to investigate the root cause and will provide updates as they learn more.
Posted Jul 30, 2020 - 17:39 CDT
This incident affected: Faculty/Staff Email and Student Email.