University of Missouri
IT System Status
Faculty/Staff Email limited connectivity
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Jul 17, 2017 - 11:56 CDT
Investigating
The Messaging team is currently investigating reports of limited email connectivity from Outlook mail clients.
Posted Jul 17, 2017 - 09:28 CDT
This incident affected: Faculty/Staff Email.