University of Missouri
IT System Status
Qualtrics
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Mar 16, 2018 - 11:31 CDT
Identified
The Division of IT has identified a problem with Qualtrics due to SSO Integration. Technicians are working to resolve it.

The estimated time to resolution is unknown
Posted Mar 16, 2018 - 11:29 CDT