University of Missouri
IT System Status
Faculty/Staff Outlook Web Access (OWA)
Incident Report for UM IT Systems
Resolved
All OWA login and redirect issues have been resolved. If you continue to see issues, please contact your local IT Help Desk.
Posted Jan 09, 2020 - 13:20 CST
Monitoring
The faculty/staff Outlook Web Access is now available. Please use the following URL’s to access webmail:
https://owa.umsystem.edu/owa

https://owa.umsystem.edu/ecp

If you continue to experience issues, please contact your local IT Helpdesk.
Posted Jan 08, 2020 - 12:27 CST
Identified
The faculty/staff Outlook Web Access is currently unavailable. Technicians are working to resolve the issue. The estimated time to resolution is unknown at this time.
Posted Jan 08, 2020 - 10:05 CST
This incident affected: Faculty/Staff Email and Other MU IT Services.