University of Missouri
IT System Status
New calling features in Microsoft Teams
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Nov 21, 2020 - 21:38 CST
Update
Faculty and staff may be receiving new meeting requests for meetings that were previously scheduled using Microsoft Teams.
Posted Nov 19, 2020 - 19:40 CST
Update
University employees may have received an email this evening (11/19) that indicates you now have new calling features in Microsoft Teams. This email is legitimate and is a result of a license upgrade with Microsoft. You do not need to report the email as phishing or be concerned
Posted Nov 19, 2020 - 18:27 CST
Monitoring
All University employees received an email this evening (11/19) that indicates you now have new calling features in Microsoft Teams. This email is legitimate and is a result of a license upgrade with Microsoft. You do not need to report the email as phishing or be concerned
Posted Nov 19, 2020 - 18:23 CST
This incident affected: Other UM IT Services.