University of Missouri
IT System Status
Call Recording
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 11:52 CDT
Investigating
Users have reported issues with Calabrio’s call recording service. Technicians are aware of the problem and have opened case with the vendor.
Posted Jul 29, 2020 - 14:57 CDT
This incident affected: Phone Services.