University of Missouri
IT System Status
CenturyLink Phone Service
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Sep 03, 2019 - 08:31 CDT
Update
It is also causing phone calls to drop.
Posted Aug 30, 2019 - 12:00 CDT
Investigating
An outage has been reported that is affecting University and Hospital phone services. It is intermittently causing one way audio on external calls. Internal Calls are unaffected at this time. CenturyLink is aware of the issue, and addressing the problem. There should be no effect on internal calls, only calls to/from external numbers.
Posted Aug 30, 2019 - 11:57 CDT
This incident affected: Phone Services.