University of Missouri
IT System Status
Personalized Email Address Tool
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Nov 30, 2018 - 09:09 CST
Identified
The personalized email address tool is currently reporting an error.
Posted Nov 29, 2018 - 16:12 CST
This incident affected: Other MU IT Services and Other UM IT Services.